[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Inf-IT DAVcl] Failed to install / configure caldavzap :(


Hi,

the simplest setup for DAViCal is to copy the "caldavzap" directory into the /usr/share/davical/htdocs/ and then open the URL in the browser. If this setup (without any config.js and/or DAViCal apache configuration changes) not works for you, then you have problem with your DAViCal installation (and need to contact the DAViCal mailing list).


JM


> On 21 Dec 2014, at 14:47, Vincent Van Houtte <vvh@xxxxxxxxxxxxx> wrote:
> 
> Hi,
> 
> Longtime user of DAViCal here and have tried Caldavzap a few times, but never succeeded in installing / configuring it properly. At this time, I presume the problem lies with me and my setup, and I would very much like to get it working.
> 
> My setup:
> * Debian Wheezy (with PHP/5.3.3-7+squeeze19 for BC reasons)
> * Apache 2.2
> * DAViCal/1.1.3.1; DB/1.2.11
> * Caldavzap 0.11.1
> 
> Errors I keep getting:
> * If I login using my own user credentials, they are accepted, but I only get a white page with text 'Resource not found' (HTTP/404)
> * If I login using someone else's credentials, I get an error HTTP/403 with following XML response:
> --
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: :Response status 403 for GET /caldavzap/
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: :***************** Response Header ****************
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: headers:-->X-Powered-By: PHP/5.3.3-7+squeeze19
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: headers:-->Server: 1.1
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: headers:-->DAV: 1, 2, 3, access-control, calendar-access, calendar-schedule
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: headers:-->DAV: extended-mkcol, bind, addressbook, calendar-auto-schedule, calendar-proxy
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: headers:-->X-DAViCal-Version: DAViCal/1.1.3; DB/1.2.11
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: headers:-->Content-type: text/xml; charset="utf-8"
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: :******************** Response ********************
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:--><?xml version="1.0" encoding="utf-8" ?>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:--><error xmlns="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav">
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:--> <need-privileges>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:-->  <resource>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:-->   <href>/caldavzap/</href>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:-->   <privilege>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:-->    <C:read-free-busy/>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:-->   </privilege>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:-->  </resource>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:--> </need-privileges>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:--></error>
> [Sun Dec 21 14:16:47 2014] [error] [client <IPaddress>] DAViCal: LOG: response:-->
> --
> 
> What I have done:
> * read the readme.txt multiple times
> * wget and unzip the zip-file into /var/www/caldavzap + chowned all files by www-data (and even chmod 770...)
> * added an 'Alias /caldavzap/ /var/www/caldavzap' to my davical-virtualhost
> * I tried adding a Directory-section for caldavzap inside the davical virtualhost
> * I tried various combinations of var.globalAccountSettings and var.globalNetworkCheckSettings and var.globalNetworkAccountSettings
> * I have always run ./cache_update.js (as root) between changes to the config
> 
> Auth: My Davical setup uses the internal database for authentication/authorization (I should update it to using Kerberos/LDAP, but that means a lot of reconfiguring of the clients, not to mention things that could go wrong)
> * I tried without changing anything in config.js and/or auth-files
> * I tried with generic auth (with both the base URL for davical as well as a test base URL in which I have succesfully added Kerberos and Basic auth)
> 
> Thank you for any help or guidance you can provide!
> 
> Kr,
> Vincent

Attachment: smime.p7s
Description: S/MIME cryptographic signature


Follow-Ups:
Re: [Inf-IT DAVcl] Failed to install / configure caldavzap :(Vincent Van Houtte <vvh@xxxxxxxxxxxxx>
References:
[Inf-IT DAVcl] Failed to install / configure caldavzap :(Vincent Van Houtte <vvh@xxxxxxxxxxxxx>