[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Inf-IT DAVcl] Update to 0.13.1 seems to fail


Thank you, so I  try the nginx directive :

add_header Cache-Control "max-age=0, must-revalidate, no-cache, no-transform, private";




On 10/30/2015 05:27 PM, Ján Máté wrote:
Because your server previously returned wrong cache header (instead of the one configured in .htaccess) and your browser cached the cache.manifest?

JM

On 30 Oct 2015, at 5:01 PM, Pierre Couderc <pierre@xxxxxxxxxx> wrote:

In  nginx access.log, I see :
GET /caldavzap/cache_handler.js HTTP/1.1" 200 2267 "https://davical.couderc.eu/caldavzap/"; "Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.3.0"

but no request for cache.manifest.
So the question seems to me : why the browser does not look for cache.manifest ...?

On 10/30/2015 10:53 AM, Ján Máté wrote:
Maybe your nginx not sends proper cache headers (see the .htaccess file) and your browser (or proxy) use "standard cache" in addition of HTML5 cache.

The cache headers in .htaccess MUST BE USED to prevent additional caching (except the HTML5 cache). Your only solution is to delete your browser local cache (and force expire all caches on proxies if you use any).


JM


On 30 Oct 2015, at 10:49, Pierre Couderc <pierre@xxxxxxxxxx> wrote:

I have overinstalled Caldavzap 0.13.1 (my files are dates sept 22 15:30) on a (nice) no config davical/caldavzap installation.
And all seems to work except I still have the message inviting to install "0.13.1 (you have0.12.1)".
I have restarted nginx, chash_update.sh....

What do I miss...?

Thnak you
PC



References:
[Inf-IT DAVcl] Update to 0.13.1 seems to failPierre Couderc <pierre@xxxxxxxxxx>
Re: [Inf-IT DAVcl] Update to 0.13.1 seems to failJán Máté <jan.mate@xxxxxxxxxx>
Re: [Inf-IT DAVcl] Update to 0.13.1 seems to failPierre Couderc <pierre@xxxxxxxxxx>
Re: [Inf-IT DAVcl] Update to 0.13.1 seems to failJán Máté <jan.mate@xxxxxxxxxx>