[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Inf-IT DAVcl] Help for starting...


Dario,

Cross-domain setup is documented in the README[1] file (third item).

Regards,
Julien

[1] https://www.inf-it.com/caldavzap/readme.txt


-------- Message original --------
Sujet : Re: [Inf-IT DAVcl] Help for starting...
De : Dario Palmisano <Dario.Palmisano@xxxxxxxxx>
Pour : davclients@xxxxxxxxxx
Date : 07/05/2017 19:17

Hi Julien,

thanks for the suggestion. Looking the web console (why I did not do that
before...) the problem it is clear:

Cross-Origin Request Blocked:

Now I need understand how to proceed to solve this in DAViCal (I suppose)

Thanks and regards

Dario



On Sunday 07 May 2017 18:40:04 you wrote:
Hi Dario,

Did you try to put the name of a resource in "href" ? For example :
http://calsrvtest2.icgeb.org:81/caldav.php/MyUsername/MyCalendar/

Also, did you check your browser console ?

Regards,
Julien


-------- Message original --------
Sujet : [Inf-IT DAVcl] Help for starting...
De : Dario Palmisano <Dario.Palmisano@xxxxxxxxx>
Pour : davclients@xxxxxxxxxx
Date : 07/05/2017 18:24

Hello,

I am very new to caldavzap and I would need some help.

I set up davical test server which provide not encrypted access (to avoid
problems with selfsigned certificates).

I installed caldavzap and edited config.js comenting out the "var
globalNetworkCheckSettings={", and as I wanted to start simple I
configured the

var globalAccountSettings=[
			{
				href:
'http://calsrvtest2.icgeb.org:81/caldav.php/MyUsername/',
				userAuth:
				{
					userName: 'MyUsername',
					userPassword: 'MyPassword'
				},
				timeOut: 90000,
				lockTimeOut: 10000,
				checkContentType: true,
				settingsAccount: true,
				delegation: true,
				hrefLabel: null,
				forceReadOnly: null,
				ignoreAlarms: false,
				backgroundCalendars: []
			}
		];

But I get white page (used several browser, with same behaviour), on the
server side I see in the access_log a generous traffic, but not relevant
errors. I run cache_update.sh quite often.

In a previous test I was connecting to calendarserver which seem not
provideing stuff to avoid the cross-domain problem, but again I cannot
make it work.

Maybe I am missing something fundamental

Thanks in advance for any help

Regards

Dario




Follow-Ups:
Re: [Inf-IT DAVcl] Help for starting...Dario Palmisano <Dario.Palmisano@xxxxxxxxx>
References:
[Inf-IT DAVcl] Help for starting...Dario Palmisano <Dario.Palmisano@xxxxxxxxx>
Re: [Inf-IT DAVcl] Help for starting...Julien Métairie <ruliane@xxxxxxxxxxx>
Re: [Inf-IT DAVcl] Help for starting...Dario Palmisano <Dario.Palmisano@xxxxxxxxx>