[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Inf-IT DAVcl] Login Page no longer visible


Hi Werner,

mime types are returned by your web server (e.g. Apache). There is a web server config which says something like:

.html        text/html
.txt           text/plain
.js             text/javascript
...
...

It looks like your web server (which returns the static javascript files) thinks that .js is text/html => it is 100% server configuration problem (NOT CardDAV/CalDAV server and NOT InfCloud client configuration).

Also don't forget to execute the cache_update.sh after every change of your web server config (because your browser can cache the old headers even if the server returns the correct ones after you fixed your the server config).


JM

> On 9 Feb 2020, at 10:18 AM, Werner Joss <werner@xxxxxxxxxxxxxxxxxxxxx> wrote:
> 
> Hi Jan,
> Thanks for reply - and no, I did not change anything since it used to work.
> But from the browser console output, I suppose the configuration is not loaded correctly, see the attached screenshot,
> Telling me the MIME type of file config.js is wrong.
> As a result, globalInterfaceLanguage is not defined in main.js
> In config.js, the corresponding line is
> 
> var globalInterfaceLanguage='de_DE';
> 
> I'm not sure how to change the MIME type of config.js ?
> 
> Werner
> 
> Am Samstag, 8. Februar 2020, 19:59:22 CET schrieb Ján Máté:
>> Hi Werner,
>> there is nothing what can block the client from working if your client configuration or server configuration is the same. You very probably changed something somewhere.
>> The only thing you can do is to check the console.log in your browser ...
>> JM
>>>>> On 8 Feb 2020, at 09:17, Werner Joss <werner@xxxxxxxxxxxxxxxxxxxxx> wrote:
>>>> I'm just stumbling over an issue, that has been there then and now already in the past, but now seems to be persistant:
>>>> I can no longer log into my infcloud instance as the Login screen is just empty.
>>>> Looking in the page source in the Browser, I see that all containers have the attribute display:none
>>>> Especially also
>>>> <><div id="LoginPage" style="opacity: 1; display:none">
>>>> What could I try to solve this ?

PNG image


Follow-Ups:
Re: [Inf-IT DAVcl] Login Page no longer visibleWerner Joss <werner@xxxxxxxxxxxxxxxxxxxxx>
References:
Re: [Inf-IT DAVcl] Login Page no longer visibleWerner Joss <werner@xxxxxxxxxxxxxxxxxxxxx>