[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Inf-IT DAVcl] Past-due todos don't immediately show up


Hi Ján,

I'd love to, but this is a home/personal LAN-only server running on my desktop (whenever I start it), not set up to be accessed from the internet - I don't even have a fixed IP. That said, the server I use is Baikal (with digest auth), the Apache log entries between me logging in and the two todo items showing up are pasted below, and I'd be glad to send you / sniff any other traffic you might find useful - just let me know how else I can help...

- Attila

[22/Apr/2014:20:47:03 +0300] "PROPFIND /cal.php/principals/ HTTP/1.1" 401 292 [22/Apr/2014:20:47:04 +0300] "PROPFIND /cal.php/principals/ HTTP/1.1" 207 436 [22/Apr/2014:20:47:04 +0300] "PROPFIND /cal.php/principals/myuser/ HTTP/1.1" 401 292 [22/Apr/2014:20:47:04 +0300] "PROPFIND /cal.php/principals/myuser/ HTTP/1.1" 207 978 [22/Apr/2014:20:47:04 +0300] "PROPFIND /cal.php/calendars/myuser/ HTTP/1.1" 401 292 [22/Apr/2014:20:47:04 +0300] "PROPFIND /cal.php/calendars/myuser/ HTTP/1.1" 207 5218 [22/Apr/2014:20:47:04 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 401 292 [22/Apr/2014:20:47:05 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 207 15309 [22/Apr/2014:20:47:05 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 401 292 [22/Apr/2014:20:47:05 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 207 187 [22/Apr/2014:20:49:04 +0300] "PROPFIND /cal.php/principals/myuser/ HTTP/1.1" 401 292 [22/Apr/2014:20:49:04 +0300] "PROPPATCH /cal.php/principals/myuser/ HTTP/1.1" 401 292 [22/Apr/2014:20:49:05 +0300] "PROPFIND /cal.php/principals/myuser/ HTTP/1.1" 207 978 [22/Apr/2014:20:49:05 +0300] "PROPPATCH /cal.php/principals/myuser/ HTTP/1.1" 403 540 [22/Apr/2014:20:49:05 +0300] "PROPFIND /cal.php/calendars/myuser/ HTTP/1.1" 401 292 [22/Apr/2014:20:49:05 +0300] "PROPFIND /cal.php/calendars/myuser/ HTTP/1.1" 207 5218 [22/Apr/2014:20:49:05 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 401 292 [22/Apr/2014:20:49:05 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 403 275 [22/Apr/2014:20:49:05 +0300] "PROPFIND /cal.php/calendars/myuser/default/ HTTP/1.1" 401 292 [22/Apr/2014:20:49:05 +0300] "PROPFIND /cal.php/calendars/myuser/default/ HTTP/1.1" 207 18026 [22/Apr/2014:20:49:05 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 401 292 [22/Apr/2014:20:49:05 +0300] "REPORT /cal.php/calendars/myuser/default/ HTTP/1.1" 207 27535




On 22-Apr-2014 09:26, Ján Máté wrote:
Hi Atilla,

the problem you described may depend on the server you use. We use time range filtering for server which supports that functionality, otherwise we use completely different synchronization. If you want a really fast solution please create a demo server/account (+ send me a private email with credentials) and we can check where is the problem.


JM

On 21 Apr 2014, at 21:22, Attila Asztalos <attila.asztalos@xxxxxxxxx> wrote:

I'm using CalDavZAP 0.10.0.5 and right after upgrading from an older version I've noticed that an event that is long past due (last year) but still not completed (still "needing action") is not shown in the todo list - but after a short while (the first auto-reload I assume - about 2 minutes) it does show up without any intervention from me. I confirmed the issue by creating a brand new todo with a future due date (showed up immediately after logging in) which I then modified to have a due date in the past (started showing up with a delay after login, just like the other one).

- Attila




Follow-Ups:
Re: [Inf-IT DAVcl] Past-due todos don't immediately show upJán Máté <jan.mate@xxxxxxxxxx>
References:
[Inf-IT DAVcl] Past-due todos don't immediately show upAttila Asztalos <attila.asztalos@xxxxxxxxx>
Re: [Inf-IT DAVcl] Past-due todos don't immediately show upJán Máté <jan.mate@xxxxxxxxxx>