[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Inf-IT DAVcl] CalDavZAP does not show one of my calendars


Hi Rudolf,

finally we found where is the problem. The result from the server is successfully received (207 code) but the XML from your server is NOT VALID.

And the problem is, that one of your events (see the output from XML validator below) contain a special character (0x12) which not allowed in XML 1.0 (check: http://en.wikipedia.org/wiki/Valid_characters_in_XML).

So this is a very rare a very specific bug and needs a fix in DAViCal.


JM


On Jul 24, 2013, at 10:46 PM, Graf Roit <graf.roit@xxxxxxxxx> wrote:

> Hello,
> 
>>> Hello,
>>> 
>>> Am 24.07.2013 um 21:25 schrieb Ján Máté <jan.mate@xxxxxxxxxx>
>>> 
>>>>> I've got an ics-File containing the problematic calendar. It is dumped via wget direct from the davical database. Uncompressed 116k. Not so big as i thought. Would this help? 
>>>> 
>>>> I don't think that this can help to debug the issue, because this problem is related to calendar-multiget REPORT (we get raw data from the server without processing the content). Data processing is performed ONLY if this request is successful ...
>>> 
>>> It's a standard DAViCal with latest patches from you. Postgresql 8.4.13, CentOS 6.4. Nothing unusal...
>> 
>> I understand, but "something" is wrong between your server and CalDavZAP ... and it is very probably the jQuery (library we use). The problem is that your bug looks very specific (browser/version, browser/version + OS/version, browser/version + OS/version + jQuery/version,  ...).
> 
> Ok. Tomorrow i try to load the calendar into a test account, but i mean to remember DAViCal's import function is not very reliable.
> 
> I give you info on success.

Attachment: smime.p7s
Description: S/MIME cryptographic signature


Follow-Ups:
Re: [Inf-IT DAVcl] CalDavZAP does not show one of my calendarsGraf von Roit zu Hoya <graf.roit@xxxxxxxxx>